Zeilenumbrüche in Excel für Mac ersetzen

Unter OS X funktioniert das Suchen-Ersetzen von Zeilenumbrüchen nicht. Hier helfen folgende Workarounds …

Möglichkeit 1*

Zeilenumbrüche über Hilfsspalte mit Formel entfernen

=WENN(ISTFEHLER(FINDEN(ZEICHEN(10);A1));A1;ERSETZEN(A1;FINDEN(ZEICHEN(10);A1);1;" „))

 

Möglichkeit 2*

Zeilenumbrüche mit Makro entfernen

Sub ZeilenumbruecheEntfernen() 
Cells.Replace What:=Chr$(13), Replacement:=" ", _ 
LookAt:=xlPart, SearchOrder:=xlByRows, MatchCase:=False 
End Sub

 

Wer andere Lösungen kennt, kann diese gerne als Kommentar hinterlassen …

*getestet mit Microsoft Excel für Mac 2011

1 Kommentar

  1. Zuerst kam eine Fehlermeldung, aber dann habe ich die Anführungszeichen nochmal per Hand ersetzt und dann ging es. Danke 🙂

Schreibe einen Kommentar

Pflichtfelder sind mit * markiert.


CAPTCHA

*