Zeilenumbrüche in Excel für Mac ersetzen

Unter OS X funktioniert das Suchen-Ersetzen von Zeilenumbrüchen nicht. Hier helfen folgende Workarounds …

Möglichkeit 1*

Zeilenumbrüche über Hilfsspalte mit Formel entfernen

=WENN(ISTFEHLER(FINDEN(ZEICHEN(10);A1));A1;ERSETZEN(A1;FINDEN(ZEICHEN(10);A1);1;" „))

 

Möglichkeit 2*

Zeilenumbrüche mit Makro entfernen

Sub ZeilenumbruecheEntfernen() 
Cells.Replace What:=Chr$(13), Replacement:=" ", _ 
LookAt:=xlPart, SearchOrder:=xlByRows, MatchCase:=False 
End Sub

 

Wer andere Lösungen kennt, kann diese gerne als Kommentar hinterlassen …

*getestet mit Microsoft Excel für Mac 2011

3 Kommentare

  1. Zuerst kam eine Fehlermeldung, aber dann habe ich die Anführungszeichen nochmal per Hand ersetzt und dann ging es. Danke 🙂

  2. Die Wechseln Funktion in Excel hilft mehrere Zeilenumbrücke in einer Zelle zu ändern. Die Formel oben wird so eingegeben:
    =WECHSELN(A1;ZEICHEN(10);“ „)

    So können z.B. doppelte Zeilenumbrüche so durch einfache ersetzt werden:
    =WECHSELN(A1;ZEICHEN(10)&ZEICHEN(10);ZEICHEN(10))

  3. Beim Posten verändern sich die Anführungszeichen in der oberen Fuktion.
    Bitte ersetzen durch zweimal Anführungszeichen oben mit Leerzelle dazwischen.

Schreibe einen Kommentar

Pflichtfelder sind mit * markiert.


*