„Send to Inbox“ mit OmniFocus 2

Mit OmniFocus 1 (von der Firma The Omni Group) war es möglich, Nachrichten direkt aus einer E-Mail auszuschneiden und die Text-Schnippsel in OmniFocus als To-Do einzufügen. Hierzu musste lediglich in den OmniFocus-Einstellungen das Mail-Script „Clip-o-Tron 3000“ aktiviert sein. Leider ist diese Funktion in OmniFocus 2 nicht mehr enthalten*.

Hier hilft derzeit folgender Workaround: Weiterlesen … “„Send to Inbox“ mit OmniFocus 2” »

Zeilenumbrüche in Excel für Mac ersetzen

Unter OS X funktioniert das Suchen-Ersetzen von Zeilenumbrüchen nicht. Hier helfen folgende Workarounds …

Möglichkeit 1*

Zeilenumbrüche über Hilfsspalte mit Formel entfernen

=WENN(ISTFEHLER(FINDEN(ZEICHEN(10);A1));A1;ERSETZEN(A1;FINDEN(ZEICHEN(10);A1);1;" „))

 

Möglichkeit 2*

Zeilenumbrüche mit Makro entfernen

Sub ZeilenumbruecheEntfernen() 
Cells.Replace What:=Chr$(13), Replacement:=" ", _ 
LookAt:=xlPart, SearchOrder:=xlByRows, MatchCase:=False 
End Sub

 

Wer andere Lösungen kennt, kann diese gerne als Kommentar hinterlassen …

*getestet mit Microsoft Excel für Mac 2011

Dateneingabe unter FileMaker mit MySQL

Folgendes Szenario

Frontend (Dateneingabe): FileMaker Pro Advanced 12
Backend (Datenbank): MySQL-Tabelle
ODBC-Treiber: Actual Technology
FileMaker-Dialogmeldung:
Bei der Dateneingabe bzw. Datenänderung erscheint ein FileMaker-Dialog mit folgender Fehlermeldung bzw. Nachfrage (siehe Abb.1).

„Der Datensatz wurde durch einen anderen Benutzer geändert, seit Sie ihn bearbeiten. Wollen Sie die Änderungen speichern und die des anderen Benutzers überschreiben?“

Abb. 1, FileMaker-Dialog

Abb. 1, FileMaker-Dialog


 

Lösung

Um diese Meldung „abzustellen“, hilft folgende Vorgehensweise:
 

1. FileMaker-Script erstellen

Script: Schreibe Änderung Datens./Abfrage [ Schreiben erzwingen ]
Scriptname vergeben: z.B. „BeiDatensatzSpeichern_MySQL“
Kleiner Haken – große Wirkung: Haken setzen bei „ESS-Sperrkonflikt überschreiben“ (siehe Abb.2)

Abb. 2, FileMaker-Script (External SQL Data Sources)

Abb. 2, FileMaker-Script (External SQL Data Sources)


 

2. Ereignis/ScriptTrigger in den Layouteinstellungen setzen

– In den Layoutmodus wechseln -> Register „Script-Trigger“
– Haken setzen bei Ereignis „BeiDatensatzspeichern“
– Das unter Schritt 1 erstellte Script auswählen, im Beispiel „BeiDatensatzSpeichern_MySQL“
(siehe Abb.3)

Abb. 3, FileMaker-Ereignis

Abb. 3, FileMaker-Ereignis

 
 
 

Weitere Infos zum Thema FileMaker ESS (External SQL Data Sources) hier …

Mehrfache Einträge im Kontextmenü „Öffnen mit“ entfernen [Mac]

So sehen mehrfache Einträge im Kontextmenü aus

Hin und wieder kommt es unter Mac OS X Mountain Lion zum Phänomen, dass im Kontextmenü „Öffnen mit …“ die Programme mehrfach angezeigt werden.
Hier hilft folgende Vorgehensweise:
– Terminal starten
– Kommando absetzen:

/System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user

– Finder neu starten (Strg+Alt+esc)
Jetzt sollten die Einträge wieder einzeln angezeigt werden.